Blank / White / Pink Screen Bug

The new Supernotes 2.1.0 release introduced some major infrastructure improvements that needed to be made for future versions, in particular the upcoming offline mode. A side effect of this is that some users are experiencing a blank / white screen bug when launching the Supernotes app (desktop / mobile or web) after the update. Here’s how you can fix this:

Mobile Apps

Try force closing the app, by swiping it up from the app switcher. If that fails after a few attempts, delete the app from your iPhone or Android device and then do a fresh install via Testflight or Google Play. Use the installation links to the mobile apps from downloads page.

Desktop Apps

Quit your app. And then delete the supernotes folder located in:

  • Mac OS: ~/Library/Application Support/
  • Windows: C:\Users\<you>\AppData\Local\
  • Linux: ~/.config/

If all else fails, do the above and delete the app. And then download the latest version from our downloads page.

Web Apps

Clear the local storage of the Supernotes within the developer tools of your browser, e.g in Chromium browsers go to ‘Application’ > ‘Storage’ > ‘Clear site data’ as below…

Or open the web app in an incognito window.

If you are experiencing this and the above steps do not help, please get in touch with us asap ( and we on hand to assist immediately.

We’ve moved any conversations here, that were originally posted in the Supernotes 2.1.0 announcement.

1 Like

The update has broken Supernotes on both macOS and iOS for me. Both apps get stuck on launch (macOS goes full white after the SN logo briefly appears, and iOS is stuck on the SN logo).

1 Like

Hi James,

Sorry to hear this! We did some major improvements to how the cache works on Supernotes, so the previous store one will break the newly updated app. It should automatically reset the cache. Please check you are running (2.0.0 Build 14 on iOS – try force closing or uninstalling or re-installing if it doesn’t work) and for the desktop app uninstalling and re-downloading it from the download page (Download | Supernotes).

Apologies for the inconvenience, and we’re looking forward to hearing your feedback once the apps are up and running for you.

I force updated in TestFlight to build 14, and downloaded ARM 2.1.0 from the website. Both apps are now stuck on a fully white screen.

Is there any other way I can force reset the cache?

1 Like

Re. iOS. Have you tried force closing the app, by swiping it up from the app switcher. If that fails after a few attempts, delete the app from your iPhone and then do a fresh install via Testflight.

Re. Desktop. Try deleting the entire Supernotes folder located in /Users/YOUR_USERNAME/Library/Application Support/Supernotes.

Sorry that this is happening, we had thoroughly tested this and hoped we were able to mitigate this for most users. There were some infrastructure improvements that needed to be made for future versions that were hard to mitigate perfectly.

Additionally the web-app should still be working so if you need that is always a good backup in the very short term.

Let us know how you get on with getting the apps to work.

Both of those tips worked. Thank you!

Sorry that this is happening, we had thoroughly tested this and hoped we were able to mitigate this for most users.

It happens, don’t worry. Thank you for your extremely quick support in helping me to get it fixed!


The Android app doesn’t work at all for me any more. I just get a blank screen. I tried clearing the cache without success. I tried uninstalling and reinstalling with no success. Still just a blank screen. Fortunately the web app in a mobile browser still works, so this is my workaround for now.

Hi @michaeldurland, did you try closing the app from Android’s app switcher while it was installed?

Is this the approximate process you used cleared the cache? You will want to make sure you clear all data if possible, including anything called “storage” or similar, as that is where the problem is happening.

Hi @connor,
Yes, I cleared the cache and the storage. Still blank screen.
Then I uninstalled the app completely.
Then I hard-powered down my device.
Then I turned it back on, and reinstalled the app. Still blank screen.
Sorry, nothing has worked so far.

Hi @michaeldurland,

We’re very sorry to hear that this is an ongoing issue for you. Thanks for following all the steps, and letting us know that it hasn’t been working. Could you try uninstalling the app, and then downloading it via the new open testing link –

Also if you could let us know which version of Android you are running and which device, that’d be very helpful for us to debug.

Hi @tobias,
I uninstalled, and reinstalled using the link provided. Still just a blank screen after the “sn” splash screen.
I’m on Android 9, Android security patch level May 1, 2019. Phone LG G6. Kernel version 3.18.120, Build number PKQ1.190522.001, Software version VS98830b.

Thanks for the further info @michaeldurland,

We’re looking into this right now for you. I’ve just spun up an emulator running Android 9, and it seems like the app is throwing an error only on this version of Android. Apologies for this, we will try and push a fix as soon as we can.

Hi @michaeldurland,

We’ve looked into this thoroughly over the weekend, testing many different Android devices and emulators with varying builds of Supernotes.

The Supernotes mobile apps are built with some of the latest technologies and frameworks so they run super snappy and fast, providing a native-like experience - especially with new notifications and sheets in the latest 2.1 update. Unfortunately some of these frameworks make use of some of the newer Android APIs and don’t support Android 9 or lower. We’ve updated our downloads page with the new requirements (Android 10+ and iOS 13+).

We’re realise this isn’t great if you want to run Supernotes on Android 9, but this might be a good opportunity to update to a newer version if possible. However, we will continue to support and improve our mobile PWA for older devices :slight_smile:

Thanks @tobias. As an app developer myself, I understand the need to let go of old OS versions. This gives me another reason to upgrade my aging phone.

1 Like

Supernotes isn’t opening. I already reinstalled it and just receive a pink screen:

macOS Monterey Version 12.3
Supernotes Version 2.1.1

Hi @bkemmer, sounds like you are encountering the Blank / White / Pink Screen Bug. Please follow those steps, and let us know if that resolves it for you :slight_smile:

1 Like

Thank you, deleting the folder worked great for me on Windows 10