Issue on Fedora 36 - Supernotes-2.2.0.AppImage

I Upgraded to Supernotes-2.2.0.AppImage yesterday and I am getting the following error now when I launch the app and try and logon:

When I click Log In I get directed to Chrome at the following URL which ends in an error:

Any advice is appreciated.

Hi @bmccafferty, thanks for the report. We are currently investigating this and will get back to you asap!

In the meantime, please use the web app on

1 Like

Hi @bmccafferty,

I cannot replicate any problems on our end.

We now require linux users to install the AppImage rather than simply run it. so we can open the app using your web browser for authentication. Please try installing the app using AppImageLauncher if you haven’t already :slight_smile:

EDIT: I have just installed Fedora 36 ARM and have been able to replicate the issue. Seems like our deeplink check isn’t working correctly, I will try to push a fix this evening.

1 Like

Cracking thanks.

The app just auto updated I let it do its thing but I can try and reinstall on Monday if needed

I only use the fedora desktop at work I have a Mac at home and it works like a charm

Thanks for the fast reply :slight_smile:


Hi @bmccafferty,

We’ve pushed some improvements in the 2.2.1 update. Please try installing a fresh version of the app using AppImageLauncher and let us know if that fixes it for you :slight_smile:

I installed AppImageLauncher and Intergrated SuperNotes but sadly the same issue with 2.2.1

If there is any debug logs or anything that would help please let me know.

The Web App works fine just not the desktop one (It was fine before the latest updates)


If I override it It still wont logon (But I do get a logon page in the browser, but it does not redirect to the app)

Hi @bmccafferty,

Thanks for the follow up! Sorry it’s not been working for you. Fortunately it *should* be an easy fix.

The issue lies with your browser not recognising the custom URL protocol supernotes://. If you go into your default browser settings, there should be an ‘Applications’ section like in the Firefox settings below.

There should be a content type called supernotes. If you modify the action to “Use other…” > then select the Supernotes app in your Applications folder. Then open Supernotes and try logging in again, it should work.

The “Application installation checks fail” always on Fedora at the moment, but as you’ve noticed the override will always work in the meantime. Regarding other Linux distros, Ubuntu is the most reliable, working 100% of the time in our testing.