Check boxes don't work consistently in desktop app (on lists created from a template)

Sometimes they work, but usually clicking on a checkbox does nothing for pinned cards. Only editing the card and typing an “X” fills the checkbox. This workflow is essential for quickly checking off lists for example.

I’m not seeing an issue myself, what environment are you in when experiencing this? For example, mobile app, web app, desktop?

1 Like

Desktop app, Mac OS. The list is from a template I created. I just discovered that clicking “see more / see less” at the bottom of the card sometimes reactivates the checkbox functionality.

(I have no issues with pinned cards in the iOS app.)

1 Like

Hi @noremac, thanks for the report. I am unable to replicate this as well.

Could you try logging out and then back into the desktop app? If that doesn’t work try re-downloading the desktop app from our download page – make sure you download the correct version for your Mac device (press the switch to toggle the ARM / Apple Silicon download).

If after these steps this still doesn’t work, try replicating this behaviour in the web app? That will let us know if this issue is localised to the desktop apps or not.

1 Like

This behavior is just limited to the desktop app. I run the Intel version of the app, and I’ll try re-downloading tonight. Checkboxes on the web app and iOS app work normally.

Also this bug is limited to checkbox lists created from a template. I’ll change the topic name, since this bug also affects the card in the Noteboard and not just the Pinned sidebar. (Clicking “see more” and “see less” seems to temporarily restore the checkbox function on the desktop app.)

I just upgraded the MacOS to Monterrey and reinstalled Supernotes. So far so good. No more check box bugs. I’ll report back if the problems resurface.

1 Like