Element View cut off when using '/' when the title of the card is not visible

Description
When adding an element to the card, the element view only appears next to the ‘+’ icon on the right top corner of the card. This is perfect. However, when you edit a card but somehow you end up with the title not displayed in the screen and you try to add an element with ‘/’, the element view will still appear next to the ‘+’ icon, thus, giving a cut off view and one unable to have a total vision of what trying to add to the card.
A screenshot is better than 1000s words:

Browsers where I have encountered this bug:

  • Safari
  • Chrome

Note: These are only the browsers that I have tried. I am not saying that in other browsers this bug does not exist.

That said, I am totally sure your team will exactly know how to fix this so the users can have a total vision of what they are doing regardless of how the card is placed on the screen. But If this is an intended behaviour, please, could I ask you to reconsider this issue?

Thank you very much.

5 Likes

Hi @alexwilkom, thanks for your very thorough report on this - it is very helpful. Don’t worry it is not an intended behaviour, and we are looking to push a fix for this in one of the next updates for Supernotes!

Our next major update, 1.5, is coming out in the next few days - so if not in that update, definitely the next!

1 Like

Because side panel always pops up at the right top of the note card box, I cannot see it when I typed / to open side panel on the bottom of long notes.

Demonstration

Because this was too pesky to me, I categorized this post as Bug report.

Thanks!

Hi @laff, we are aware of this issue (merging this into the existing topic).

One of the reasons we haven’t fixed yet, is that it’s something we are going to address with the upcoming new editor, since we will adapt the “Universal Coupler” (what we call the sidepanel as it ‘couples’ elements to a card) to be more streamlined.

1 Like

Then new universal coupler will show more natural response! Great change!
Is this feature planned to be shipped at 1.7?

The new editor will not be available in 1.7, but is very high priority and we will focus on releasing that next :zap:

1 Like

If you create a long enough card where you have to scroll and the “+” that opens the menu by clicking is not visible, the menu will never be rendered if you press /. And like the title says, it still receives input in this state, and I believe the various options in the menu could even be selected if you typed the right thing and pressed enter. Even if you scroll up after pressing / the menu will still not show up until you close it in some way and then open it again. (usually I just press the button at that point because I think pressing / will scroll? can’t remember)

I have not done thorough testing to make sure that the reproduce condition is that the “+” button is not visible, it might be that card is long enough that the entire menu would be invisible if it opened.

This is unfortunately a limitation of the current editor, we currently working on the solution with the new editor where it will both appear inline and next to the “+” button. I have merged this into the existing issue.