Self-closing backticks for coding-blocks not functioning correctly on Windows

Hi - just a quick question … would it be possible to allow auto-closing of the backticks for a codeblock in SN?
At home I have a streamdeck with shortcuts, but when I am not at home it would be super helpful.

Hi @isaiur, thanks for your feature request.

We already have autocomplete for backticks for codeblocks, type three backticks and it will automatically self close.

CleanShot 2023-07-13 at 12.45.48

Could you possibly take a screen recording of your flow / is the current self-closing implementation not working?

That’s weird - obviously I cannot imagine you haven’t an autocomplete - but it’s not working for me.

Hi @isaiur, could you please try re-downloading the desktop app from Download | Supernotes? That should fix it

Unfortunately not quite. Now they are turning grey as markdown but I also get two first then another two and the fifth and sixth as I click the button.

Can you replicate on the web app? Please send another gif as it’s very helpful to diagnose the issue :slight_smile:

I have the same problem on the web app. Here is the new screen rec.:


Very strange, we will look into this, which browser, app and OS are you using?

Thank you! I’m using Windows 11 - Version 22H2, Browsers are firefox and chrome - on the iPhone beta app it’s working.

Great thanks, I’ve modified this to be a bug report and we will fix this in the next release

Hi - anything new on this?

It still behaves weird on my side. I just took a quick screen record. The weird thing is when I use my stream deck with a hotkey it works … but when I type the backtick on my own it doesn’t work


Hi @isaiur,

Unfortunately no update on our end, we’ve never been able to replicate this. My old assumption is that your backtick key is somehow different on your physical keyboard (since it works on iOS and on your stream deck).

Could you try pressing the different keys in this keyboard recorder and screenshot the result? Are they different between your physical deck and your keyboard?

1 Like

I’m sorry for having that trouble on my end.

There’s also a weird behavior when using this Keyboard Event Viewer. My cursor is inside this input element - i click shift + the backtick once and nothing happens. I need to click again on the backtick and then two `` appear as you can see. I don’t know why … I am using a logitech mx master 3.

This is what I get on my Macbook. Seems like you’re holding down Shift to press the backtick? This may be the issue, out of interest what keyboard layout (i.e QWERTY etc) are you using?

Also your keydown event registers two backticks. Very odd.

1 Like

I think this is a feature of your system / keyboard to quickly add diacritics to characters. I am assuming if you press backtick and then the “e” character you will end up with “è”, correct? This is what is called a dead key. Quite common for International keyboard layouts to do this.

Assuming this is the case, what is happening is that when you press one backtick it is making a temporary diacritic, then when you press it a second time it is stabilizing as two (because the system knows you don’t want to add a backtick to a backtick). You do this again and there is never a moment when there are three backticks (what we are waiting for to autocomplete), as you sorta go straight from two to four.

Not sure this is something we can fix on our end, I think you will need to disable this behavior on the keyboard / Windows level. Maybe try pressing altshift` or ctrlshift` . If that doesn’t work, MX Keys should allow you to set your own output for that particular key I believe, which you can force to just be a backtick instead of a modifier. If you are unable to get this working on your end let us know and we will see if there is somehow a way to work around this, but off the top of my head not sure how.

Or if I’m entirely wrong on this let us know as well :slight_smile:


I learned that it’s called dead key, too. Yes, I end up with an è and @tobias I am using the QUERTZ layout.

Alt Shift and backtick (it doesn’t render correctly here) or Alt Shift and backtick doesn’t work - what I found are two ways:

On my stream deck I now have an hotkey which enters three backticks at once and that triggers the code block. And on my keyboard I have to press Shift + backtick and then space that enters two backticks - than the same thing again, which sends the cursor to the end and then again which triggers the code block.

Probably I will create a template for that in Supernotes when I’m not in front of my stream deck.

So, I thank you for your help and think you can close this cause it’s not a bug.