Trouble Importing Roam

Hi there,
When I import my Roam database (which apparently has 1500 “cards”), the import seems to fail, but I’m given no feedback on this. In the top right, I can click on my profile icon and see 1500 / 40 cards. You say that imported Roam cards don’t count toward your limit until they are edited, so I assumed this import should be alright. Anyways, I can’t find any of my Roam notes. They appear nowhere. Searching brings up nothing. If I refresh the page and click on my profile icon again, I see 3 / 40 cards. I’d love to give Supernotes a spin, but this is currently preventing me from diving in.

Hi @nlstrait, welcome to the Supernotes Community! Hopefully I will be able to help so you can give Supernotes a proper spin.

You’re right in thinking all imported cards do not count towards your limit, it’s only once you start interacting with them.

Since your database was quite large, it may have taken a few minutes for the data to import / migrate on our servers. If you log in now are the cards there? I definitely agree that we need to add a progress bar to clearly indicate the import progress of large databases.

If there are still no cards, the import may have failed. Either try again or maybe try to import a smaller portion of your Roam database? That way you can give Supernotes a small spin, while we take a closer look into why your import may be failing.

1 Like

Hi @tobias, thank you for your quick response! Coming back to Supernotes today after trying to import yesterday, my Roam cards are still not here, but I will try leaving Supernotes open and undisturbed for a while after importing to see what happens.

Admittedly our Import functionality is not very sophisticated at the moment, but it is something we are improving. In order to maximize security, the import mostly happens on your device, so it is hard for us to tell if something has gone wrong. But thanks again for bringing this to our attention, we will look into it! And of course let us know if you see any errors or anything like that.

1 Like

Update: I tried again to import Roam cards and left the browser window open for a few hours while I went about my day, and the cards are still unavailable. I just tried importing again, and this is what I’m getting in the console.

Let me know if any deeper log info is of use.

Hi @nlstrait,

Could you try just importing a few (say 10) of your markdown files and see what happens then?