Card parent mismatch on mobile

I’m getting a weird behaviour where a single card is being badly loaded on my mobile. On desktop, it has a parent. On mobile, it doesn’t, and so it appears in my tree. It’s the same card because I can edit it and the edits sync between devices. Tried logging out and in again on mobile to no avail.

Hi @daniela1,

Thanks for the report. Have you tried restarting the Desktop App? The cache might actually be stale with the desktop app, so it appears there is a parent when there isn’t one.

We added a button in User > Settings > Restart App so you no longer need to log out and in to reset the cache and potentially any stale data.

Have tried, didn’t work I’m afraid.

Hello there

I am experiencing the same sync issue. More precisely:

  • On desktop, I have a card without a parent (stored in “thoughts”)
  • I set a parent to the card, with no other change. The card is no longer in “thoughts” but filled with the parent.
  • On mobile, the card is still listed in “thoughts”. The parent has not changed.
  • Of course, I have restarted on both desktop and mobile, etc…
  • Now, I go back to the changed card on the desktop and I change a character in the note.
  • This time, when I open the card on mobile it’s all synced and the parent is attributed as well.
    So it looks like changing the parent of a card doesn’t enlist it for a sync. I haven’t checked other combinations (e.g.: changing a tag, etc…).


PS: kudos for a wonderful product !

Thank you for your in-depth writeup @JackLukouali, that is super helpful. We are currently changing how syncing works in preparation for the upcoming offline mode, and will make sure to investigate / fix this issue.