Cards not showing when created by contributor

I was just testing out the sharing features and I noticed when I share a card with a contributor and they add child cards, they are not shown in the account that’s actually sharing. It does work the other way round, but I’d expect this to work in both directions. In Tobias’s video about sharing it looks like this should be working.
I tried several roles like Ghost, Contributor and Editor.
The account I shared with is not a paying account, but that shouldn’t matter, right?
Is this a bug or am I missing something?

Hi @kareldries, thanks for reporting this. You are right this is not the intended behaviour, both accounts should be able to share cards with each other (irrespective if they are paying or not). I have actually just tested this and it is working fine on my end.

Could you check for me if the contributor is ‘publishing’ their cards into the parent card – this is denoted by a little blue icon in the parent badge. Also is the original author of the parent listed as a member of the card?

Hi Tobias,

I found the cause.
When you first add someone as Reader and then change their access control to Contributor after they joined, the default for publishing new cards is Unlisted. Wouldn’t it make more sense to link the default of Published / Unlisted to their current role instead of the initial one?


Good find, and great suggestion. We are already improving the way permissions are handled in the next release [1.8] and will make sure to include this as well!

1 Like

Hi, just wanted to clarify slightly here.

Whenever you have a card “opened” on the noteboard, there is an option (specific to being inside of that particular card) to either auto-publish newly created cards, or to create them as unlisted, as seen here.

This option is persistent, in that if you change that option to unlisted at some point, it will remain that way until you change it back, even across devices, for that particular card.

When you open a card for the first time with Contributor (or higher) permissions, this option defaults to publish. Reader or Ghost and you end up with unlisted, as of course they are not allowed to publish to the parent in the first place.

When someone’s role is changed, if the user has previously opened the card, this “auto-publish” option does not change. This is to prevent a situation where:

  1. Connor shares the “Ideas” card with Tobias, giving him Reader perms
  2. Tobias happily makes unlisted cards within “Ideas”, knowing they are only visible to him and for his own consumption.
  3. Connor changes Tobias’ perms to Contributor, and Tobias doesn’t really notice this.
  4. The next time Tobias makes a card within “Ideas”, the default (unbeknownst to him) has been changed to publish and shares his card with everyone, which he did not intend to do.

So I think the best way to handle this is to continue requiring users to change the auto-publish option in the Noteboard settings, even when their role is changed. Thanks for looking into it though. As Tobias mentioned, there are a number of ergonomic improvements coming into 1.8 related to permissioning (including better role propagation), so we can also revisit once that is released.

Hi Connor,

Thank you for taking the time to write such an elaborate and clear response.
As you said, some ergonomic improvements could go a long way if this means making it more clear to the end user to find this option in relation to the actual access they have.
This might be a good candidate for the help section though, depending on how 1.8 handles things obviously.